php web技術 wordpress

WordPressがParse error: syntax error…を吐いてしまったのはPHPのバージョンが原因だった

一年間のアーカイブリンクをサイドバーに入れようとして、以下の公式コードを貼り付けました。

サイト制作が完成してアップしたところ、エラーがおきてしまいました!

テンプレートタグ/wp get archives - WordPress Codex 日本語版


以前は[“hogehoge”]で配列するようでした。
コンバネを調べてみたらPHP 5.3でした。
PHPのバージョンが原因だったようです。
更にローカルのWPを調べてみると4.9(最新)
WordPress の推奨動作環境の遷移 | ぴんくいろにっき
上のブログを見てみると4.9.xは7.2が推奨されているようですね。
案件のサーバーは5.5までしか上げることが出来ませんでした。局所的な対応は出来ましたがプラグインとかコードの動作が怖いです。

-php, web技術, wordpress