php web技術 wordpress

Godiosを使ってたらエラーがでた

XserverでGodiosを使っていたら以下のようなエラーが現れた。

このエラーでググってみるとエラーを吐き出しているサイトが無数に出てきます。

公式をみるとアップデートで解決済みらしいが、今年からサブスクリプションになってしまったので、そんなお金払えるほどお賃金をもらっていないので、自分でなんとかすることにした。
ちなみに自分は全然PHPの知識とかがないので​セキュリティ的にものすごく深刻な問題を引き起こすことがあるかもしれないしサイト自体が停止してしまうかもしれないのでまねしないでください。
ソースを覗くとimageの変数が空っぽだようと言っているらしい。
更に周囲を調べるとOGPの画像を刺しているようです。
なので、Godiosの設定画面からOGPに関するチェック項目を削除する。
​こうすることでエラー文章が消えました


OGP画像を使いたい場合は別のプラグインか手書きで対応ですね
OGP画像を使いたい場合は別のプラグインか手書きで対応ですね

-php, web技術, wordpress
-